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A képernyő digitalizáláshoz szükséges minimális ismereteket foglalja össze ez a segédlet. Az
AutoCAD MAP egy komplex térinformatikai szoftver, a gyakorlat során funkcionalitásának csak a
konkrét feladat megoldásához szükséges részét használjuk.

További részletesebb leírások:
Rajztisztítás
Raszteres adatok kezelése
Térinformatikai oktatási segédlet Autodesk Map program felhasználásával

Az AutoCAD Map az Autodesk AutoCAD programjának térinformatikai funkcionalitással kibővített
változata. Az Informatika tárgy során használt AutoCAD R10 illetve AutoCAD LT2 programokban
megismert parancsok itt is használhatók.

Az AutoCAD MAP elindítása

Az AutoCAD Map program 32 bites Windows operációs rendszerben használható. A laborban levő
gépek bekapcsolása után a Windows operációs rendszer automatikusan elindul. Adja meg a
gyakorlatvezető által megadott bejelentkezési nevet és jelszót. Sikeres bejelentkezés után az
asztalon megjelenő ikonok közül kattintson duplán az AutoCAD Map ikonjára .

A képernyőn a következő ablak jelenik meg.

Az AutoCAD Map ablaka

Geodézia III http://www.agt.bme.hu/szakm/software/Geod3m...

1 of 9 02/21/2016 10:47 PM



Rajzok, rétegek beállítása

A rajzhoz adjon hozzá három további réteget, a Format>Layer menüpont segítségével vagy a 
eszköz segítségével. Ezután megjelenik a rétegek beállításai ablak. Nyomja meg a New gombot, a
listában megjelenő "Layer1" helyére írja be EPULETEK. Ismét válassza a New gombot, a réteg
neve legyen TELEKHATAROK, majd végül hozzon létre egy HRSZ nevű réteget. A munka
megkönnyítése érdekében állítsa be az új rétegek színét. Az EPULETEK és TELEKHATÁROK réteg
színe legyen eltérő, a piros színt ne használja. A vonalvastagságot (Lineweight) minden új rétegre
állítsa 0.3-ra. A réteg beállítások ablakból lépjen ki az OK gomb megnyomásával.

Réteg beállítások a digitalizáláshoz

Raszter betöltése és beillesztése

A raszter fájl beillesztését a geodéziai koordinátarendszerbe két lépésben hajtjuk végre. Először a
rasztert egy tetszőleges helyre beillesztjük, majd az őrkeresztek segítségével pontosan
transzformáljuk. A raszter fájlokat a gyakorlatvezető által megadott helyen találja meg, ez egy
hálózati meghajtó, amit a Windows Intéző programmal egy helyi meghajtóhoz kell rendelni. A
továbbiakban feltételezzük, hogy ez a meghajtó az X:. Az X:\ könyvtárban találja meg, a
vezetéknevével egyező nevű TIF fájlban. A hálózati meghajtó csatlakoztatása után válassza a
Map>Image>Insert menüpontot. Keresse ki a beillesztendő raszter fájl nevét, a megjelenő fájl
kiválasztó ablakban. A fájl kiválasztása után megjelenő párbeszéd ablakban fogadja el az
alapértelmezés szerinti beállításokat az OK gomb megnyomásával.
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Image correlation ablak

A kép bal alsó sarka az origóba kerül, a View>Zoom>Extent paranccsal a teljes raszter láthatóvá
válik.

Raszter transzformálása

A szkennelt térkép transzformálásához válassza a Map>Tools>Rubbersheet menüpontot. Ezután
ki kell jelölnie a transzformáláshoz használt őrkereszteket. Őrkeresztenként először a raszteren
kell megadni a pozíciót (Base point), majd a parancssorban kell beírnia az örkereszt EOV
koordinátáit (Reference point). Az őrkereszt raszteren történő kijelöléséhez a megfelelő részt ki
kell nagyítani a képernyőn, transzformálás közben az eszközsor nagyító, kicsinyítő gombjait
használhatja Az őrkereszt EOV koordinátáit vesszővel elválasztva kell megadnia, az AutoCAD-ben
szokásos módon. Sem a vessző elött sem a vessző után nem lehet szóköz. Legalább négy
illesztőpontot adjon meg a transzformálás során. Ha már az összes kapcsolópontot megadta, akkor
a Base point: promptnál nyomja meg az Enter billentyűt. A Select object by <Area>/Select:
promtnál válassza select-et (S betű elég) és kattintson a raszter kép keretére és nyomja meg az
Enter-t. Ha nem látszik a raszter külső kerete, akkor addig kell kicsinyíteni, amíg egy része látható
nem lesz. A rasztert az AutoCAD Map eltolja, elforgatja, nagyítja úgy, hogy a legjobban
illeszkedjenek a megadott őrkeresztek koordinátáihoz. Az egyes őrkereszteknél mutatkozó
eltéréseket (a rajzban és a raszteren lévő őrkeresztek között) mérje le (Dist parancs) és
dokumentálja egy táblázatban. Az eltéréseknek 0.2 méter alatt illene lennie, ennél nagyobb eltérés
esetén a transzformációt meg kell ismételni.

Sorszám X Y Dx Dy Távolság irány

1 0 0 0.07 0.12 0.14 60

2

3

4

átlag átlag átlag

Transzformáció hibáinak kimutatásárhoz használandó táblázat

Tipp: a táblázat kitöltéséhez szükséges adatokat az AutoCAD dist (távolság) parancsával is
lekérdezheti.
Distance = 6.2508, Angle in XY Plane = 328, Angle from XY Plane = 0
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Delta X = 5.3015, Delta Y = -3.3116, Delta Z = 0.0000

A dist parancs eredménye

Pontok megadása a transzformációhoz

Digitalizálás a képernyőn
Az épület határvonalakat és a telek határvonalakat a megfelelő rétegekre át kell rajzolnia a
raszterről. Célszerű a tárgyraszter (Tools>Drafting Settings>Object Snap fül) végpont (Endpoint)
tulajdonságát beállítani a digitalizálás megkezdése előtt. Ugyanebben a pátrbeszédablakban a
Snap fülön állíthatja be a centiméterre kerek koordináták tárolását. A HRSZ rétegre a helyrajzi

számokat mint feliratokat el kell helyezni (Text parancs). Vigyázat az eszközsorban található 
ikon nem használható, mert ez a többsoros szöveg elhelyezésére szolgál (Multiline text). A mi
céljainkhoz csak az egysoros szövegek használhatók (Draw>Text>Singleline text). Figyeljen,
hogy a helyrajzi szám feliratok beillesztési pontja a megfelelő telek belsejébe essen.

Tárgy raszter eszközsor
Először az eszközsorban jelölje ki azt a réteget, amelyre a vonalat akarja húzni. A Draw menüből

válassza a Line-t vagy az eszközsorból a  ikont. Húzza az egeret a grafikus ablakba és kattintson
az egyenes végpontjaiba. A pontos digitalizálás érdekében nagyítsa ki a rajz részleteit. Ha már
egyszer digitalizált pontba kell visszaállnia használja a tárgyrasztert. Felesleges töréspontokat ne
vegyen fel, amíg az egyenes képe a raszter vonalat nem hagyja el nem kell újabb töréspontokat
felvenni. Viszont minden olyan helyen, ahol több vonal csatlakozik mindegyik vonalat meg
szakítani. Azokon a helyeken, ahol a telekhatár és egy épület fal egybeesik, mindkét rétegen meg
kell húzni a vonalat, azaz mind a telekhatár, mind az épület rétegen a vonalaknak területeket kell
körbezárnia. Az egymáson futó telekhatár és épület vonalaknak tökéletesen egybe kell esnie.
Centiméterre kerekített koordináták esetén ez csak úgy valósítható meg, ha a telekhatárokat az
épületek sarokpontjánál is megtöri.

A munka befejezésekor illetve időnként (félóránként) mentse ki a rajzát az X:\ könyvtárába, a fájl
neve a vezetéknevével (ékezetek nélkül) egyezzen meg. Legközelebb, amikor folytatja a munkát
már csak meg kell nyitnia a rajzot (File>Open) és onnan folytatni, ahol abbahagyta.

A biztonság kedvéért készítsen másolatot a rajz fájljáról (vezeteknev.dwg) a saját floppy lemezére
vagy Pen Drive-jára.

A rajz szerkesztése

A hibás rajzi részleteket többféle módszerrel is törölheti.

Kattintson a törlendő rajz elem(ek)re és nyomja meg a Delete gombot a billentyűzeten
Modify>Erase parancs a menüből, ezután jelölje ki a törlendő elemeket, majd nyomja meg az
Enter gombot.
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A véletlenül törölt elemeket visszahozhatja az Undo parancs vagy  eszköz segítségével.

Egy vonal vagy vonallánc végpontjának elmozdításához kattintson a vonalra, a vonalon kék színű
fogók jelennek meg, melyekre az egérrel kattintva az adott pontot elmozdíthatja. A fogókat az Esc
billentyű (kétszeri) megnyomásával tüntetheti el. Több csatlakozó vonal közöt pontját is
mozgathatja a csatlakozó egyenesekkel együtt, ha a pontba befutó valamennyi egyenest kiválasztja
és utána mozgatja a közös pontot.

Egy rajzi részlet tulajdonságainak (pl. az egyik rétegről a másikra történő átmásolásához)
megváltoztatásához válassza a menüből a Modify>Properties menüpontot. A rajzi elem
tulajdonságait tartalmazó ablak jelenik meg. Az aktuálisan kiválasztott elem(ek) jellemzőit
tartalmazza, melyeket közvetlenül módosíthat. A tulajdonságok ablak a munka közben nyitva
maradhat és mindig a kiválasztott elem(ek) tulajdonságait tartalmazza.

A rajz ellenőrzése

Mindenki ellenőrizheti, hogy a rajzában mennyire pontosan csatlakoznak az egyes vonalak. Az
ellenőrzést a Map>Tools>Drawing Cleanup menüponttal kezdheti.

Rajzi hiba Magyarázat

Duplikált rajzelemek
(duplicate objects)

Részben vagy teljesen átfedő rajzelemek. Például két azonos
végpontokkal bíró vonalelem.

Túl rövid rajzelemek
(short objects)

A rajzban előforduló a megadott toleranciánál rövidebb
rajzelemek.

Alul lógás
(undershoots)

Egy vonal nem éri el a megadott tolerancián belül eső cél
rajzelemet.

Túl lógás
(overshoots)

Egy vonal, mely a toleranciát nem meghaladó mértékben
nyúlik túl egy cél rajzelemmel alkotott metszésen.

Metsződő rajzelemek
(crossing objects)

Két egymást metsző rajzelem.

Pontatlan
csatlakozások
(clustered nodes)

A megadott toleranciánál közelebb eső kettő vagy több elem
végpont.

Álcsomópontok
(pseudo nodes)

Egy olyan pont melyben csak két rajzelem végpontjai
csatlakoznak.

Lógó vonalak
(dangling objects)

Olyan rajzelemek, melyek egyik végéhez nem csatlakozik
másik rajzelem (pl. zsákutca).

Az AutoCAD Map által javítható rajzi hibák

A rajzhibák többsége esetén egy tolerancia értéket kell megadni, mely meghatározza a még
javítandó hibák mértékét. A tolerancia érték beállítása a rajztisztítás egy kritikus pontja. Ha túl kis
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tolerancia értéket adunk meg, akkor az automatikus javítás nem tudja korrigálni az összes hibát.
Ha túl nagy értéket állítunk be, akkor az automatikus javítás során értékes, szükséges részleteket
veszíthetünk el.

A rajztisztítás párbeszéd ablak csak nyomógombokat tartalmaz. Az Object Selection (objektum
kiválasztás), az Object Conversion (objektum konverzió) és a Cleanup Options (tisztítási
beállítások) megnyomása után egy-egy újabb párbeszéd panel jelenik meg. A rajztisztítási
beállítások megőrződnek, a kiválasztott objektumok kivételével, bármelyik paraméter
megváltoztatása után az OK gomb megnyomásával a tárolt paraméterek értékeit módosíthatja. A
Proceed megnyomása után, a beállított paraméterekkel megkezdődik a rajztisztítás és az aktuális
beállítások is megőrződnek.

Rajzelemek kiválasztása a rajztisztításhoz (Object Selection)

Objektum konverzió ablak (Object Conversion)

Tisztítási paraméterek (Cleanup Options)

Topológiai elkészítése
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A rajzi hibáktól mentes telekhatár réteg és a helyrajzi számok alapján egy polygon topológiát
hozhatunk létre. Ezzel ellenőrizzük, hogy minden telekhez tartozik helyrajzi szám, minden telek
határa záródik. A topológia létrehozása során az egyes telkek területét és kerületét is kiszámítja a
számítógép.

A topológia létrehozását a Map>Topology>Create menüpont kiválasztásával kezdheti. A
rajztisztításhoz hasonlóan a kiinduló párbeszédablakból itt is három további párbeszédablakot kell
kitölteni.

Topológia létrehozása

Csomópontok kiválasztása

Vonalak kiválasztása
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Centrálisok paraméterei

A topológia csak akkor hozható létre, ha a rajz teljesen hibátlan, ellenkező esetben hibaüzenetet
kapunk és a hiba helyén egy jel jelenik meg. A hiba okát ki kell javítani és ismételten meg kell
kísérelni a topológia létrehozását.

A topológia sikeres létrehozása után a Map>Object Data>Edit Object Data  menüpont
kiválasztása után egy telek helyrajzi számára kattintva a telek területét, kerületét és a határoló
vonalak számát kérdezhetjük le.

A telkekhez hasonlóan az épületek topológiáját is létre kell hozni. Ebben az esetben a centrálisok
generálását is ki kell választani, mivel az épületekhez nem hoztunk létre centrálist.

A digitális térképen szereplő pontok koordinátáit az Excel programba betölthető formában
előállíthatja, ha a rajzi állományból AutoCAD 12 DXF formátumú állományt készít az X:\ egységre,
majd a következő parancsot kiadja egy DOS ablakban:

dxf dxf_fájl_neve

Ahol a dxf_fájl_neve az AutoCAD 12 formátumú állomány neve a kitejesztéssel együtt (pl.
kovacs.dxf). Ezután az X:\ könyvtárban létrejön egy azonos nevű, csv kiterjesztésű fájl, amit már
közvetlenül betölthet az Excel programba. Erre az AutoCAD-ban és ITR-ben digitalizált pontok
összehasonlítása során lehet szüksége.

Eszközsorok
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